Back to overview
Degraded
Cannot submit Indeed Applications
Jan 08 at 10:26am CST
Affected services
Jobs
Candidate Search
Resolved
Jan 08 at 02:02pm CST
We have addressed this issue and applicants can now submit applications via Indeed
Affected services
Jobs
Candidate Search
Created
Jan 08 at 10:26am CST
When applicants are submitting an application through Indeed, the steps to submit their application are not available. We are currently addressing this issue
Affected services
Jobs
Candidate Search