Some customers may be experiencing difficulties loading the application
Resolved
Jul 31 at 10:42am CDT
The connection issues have been resolved. All customers should be able to access the application fine now.
Affected services
Jobs
Candidate Search
Insights
Email / SMS Messaging
Interview Scheduling
Background Checks
Reference Checks
Skills Tests
Onboarding
Referrals
Created
Jul 30 at 09:03am CDT
Some customers may be experiencing difficulties connecting to the application due to a network issue with our cloud provider. We are actively working to resolve this and will provide updates as soon as possible
Affected services
Jobs
Candidate Search
Insights
Email / SMS Messaging
Interview Scheduling
Background Checks
Reference Checks
Skills Tests
Onboarding
Referrals