Back to overview
Degraded

Intermittent disruptions in Onboarding

Sep 17 at 02:39pm CDT
Affected services
Onboarding

Resolved
Sep 24 at 08:09am CDT

A fix was implemented on September 20th to correct this issue. We appreciate your understanding and patience during this time. If you have any further questions or concerns, please don't hesitate to contact our support team

Created
Sep 17 at 02:39pm CDT

We're currently experiencing intermittent disruptions to our onboarding processes. Some users may be unable to start or complete these tasks. Our team is actively working to identify and address the root cause.