Back to overview
Degraded

Referrals is currently unavailable

Mar 06 at 01:39pm CST
Affected services
Referrals

Resolved
Mar 07 at 02:35pm CST

Referrals issue has been resolved, thank you for your patience while we fixed this issue!

Updated
Mar 07 at 08:38am CST

This is still an active issue and Referrals is unavailable at this time. We are working on a fix as soon as possible, thank you for your patience.

Updated
Mar 06 at 05:08pm CST

We are still actively working on resolving this issue, thank you for your patience.

Created
Mar 06 at 01:39pm CST

Our referrals platform is currently unavailable. Our teams are working on a fix, as soon as we have further updates we will follow up here