Back to overview
Degraded
Inbox and Mobile app degraded
May 08 at 12:17pm CDT
Affected services
Jobs
Candidate Search
Insights
Email / SMS Messaging
Interview Scheduling
Referrals
Login
Resolved
May 08 at 01:41pm CDT
We have identified the root cause of the issue. The issue is now resolved. Thanks for your patience!
Affected services
Jobs
Candidate Search
Insights
Email / SMS Messaging
Interview Scheduling
Referrals
Login
Created
May 08 at 12:17pm CDT
We're aware that some users are experiencing instability with the web app. Our team is actively working to resolve this and restore full functionality as quickly as possible. Thank you for your patience.
Affected services
Jobs
Candidate Search
Insights
Email / SMS Messaging
Interview Scheduling
Referrals
Login