Back to overview
Degraded
Background check ordering is degraded
Feb 25, 2026 at 7:09pm UTC
Affected services
Background Checks
Resolved
Feb 26, 2026 at 6:47pm UTC
We have resolved this issue around background checks. Thank you for your patience!
Affected services
Created
Feb 25, 2026 at 7:09pm UTC
We are experiencing an issue that has degraded our background check ordering process. We are urgently working on this and will update you as soon as this is resolved
Affected services