Back to overview
Degraded

Ability to pull Background Check reports is degraded

Mar 4, 2026 at 6:30pm UTC
Affected services
Background Checks

Resolved
Mar 5, 2026 at 7:23pm UTC

We have resolved the issue that was affecting the ability to pull reports on Background checks. Thank you for your patience!

Created
Mar 4, 2026 at 6:30pm UTC

We are experiencing an issue that has degraded the ability to pull completed background checks in app. We are urgently working on this and will update you as soon as this is resolved