Back to overview
Degraded

Minor Service Outage with our Background Check Provider

Mar 12 at 02:32pm CDT
Affected services
Background Checks

Resolved
Mar 13 at 11:20am CDT

Our vendor has resolved the issue with ordering Background checks and all orders have back ordered and been submitted. Thank you for your patience

Created
Mar 12 at 02:32pm CDT

Our background check provider is experiencing a minor service outage that may affect ordering background checks and the ability to view reports. As soon as we have additional information from our vendor we will provide an update