Back to overview
Issue Identified: Candidate Progression
Apr 15, 2026 at 2:09pm UTC
Affected services
Jobs
Interview Scheduling
Resolved
Apr 15, 2026 at 2:09pm UTC
The technical issue affecting candidate advancement has been fully resolved. You should now be able to move candidates through your hiring stages without error. We have verified the fix and will continue to monitor the system closely.
Thank you for your patience while we cleared this up.
Affected services