System Performance & Load Issues
Resolved
Apr 15, 2026 at 4:40pm UTC
We’ve cleared up the performance issues. Thanks for your patience. everything is back to running smoothly!
Affected services
Created
Apr 15, 2026 at 3:15pm UTC
We have successfully resolved the load and performance issues affecting the webapp. All features, including Candidate Search and Candidate Progression, are now fully functional and performing at normal speeds.
We are continuing to monitor our infrastructure closely to ensure continued stability. Thank you for your patience today as we worked through these challenges.
Affected services