Back to overview
Degraded

Customers may not be able to download their job applications

Feb 22 at 02:40pm CST
Affected services
Jobs

Resolved
Feb 22 at 04:24pm CST

A fix has been identified and service has been restored. Thank you for your patience.

Created
Feb 22 at 02:40pm CST

Some candidates may not be to download their applications. A fix has been identified and service should be restored soon.