Back to overview
Degraded
Emails sent from mobile devices
Mar 02 at 09:00am CST
Affected services
Email / SMS Messaging
Resolved
Mar 17 at 03:09pm CDT
The team has identified and resolved the issue.
Affected services
Email / SMS Messaging
Created
Mar 02 at 09:00am CST
Emails from mobile devices are not being delivered.
Affected services
Email / SMS Messaging