Back to overview
Downtime
Interview scheduling is down
Mar 17 at 06:10am CDT
Affected services
Interview Scheduling
Resolved
Mar 17 at 07:59am CDT
The interview scheduling feature is now restored.
Affected services
Interview Scheduling
Created
Mar 17 at 06:10am CDT
Interview scheduling is down. The team is looking into it.
Affected services
Interview Scheduling