Back to overview
Degraded
Billing integration is experiencing latency issues due to a 3rd party vendor.
Apr 17 at 09:37am CDT
Affected services
Background Checks
Reference Checks
Skills Tests
Onboarding
Resolved
Apr 17 at 11:04am CDT
A fix has been implemented by our 3rd party vendor. We will continue to monitor all activity.
Affected services
Background Checks
Reference Checks
Skills Tests
Onboarding
Created
Apr 17 at 09:37am CDT
Billing integration is experiencing latency issues due to a 3rd party vendor. Ordering any new services or viewing your billing page would be down right now. Any action that does not include billing will not be affected.
Affected services
Background Checks
Reference Checks
Skills Tests
Onboarding