Back to overview
Degraded
New users are unable to download their documents
Apr 24 at 10:18am CDT
Affected services
Onboarding
Resolved
May 12 at 03:49pm CDT
This issue has been resolved and all users are now able to download their documents
Affected services
Onboarding
Created
Apr 24 at 10:18am CDT
Any users added since April 20th will not be able to download their onboarding documents. The team is looking into this issue.
Affected services
Onboarding