Back to overview
Degraded

Customers may experience general slowness and/or timeouts

May 11 at 08:51pm CDT
Affected services
Jobs
Candidate Search
Insights
Email / SMS Messaging
Interview Scheduling

Resolved
May 11 at 09:25pm CDT

We have identified the root cause of the performance issues and have remedied the situation. We apologize for the inconvenience!

Created
May 11 at 08:51pm CDT

We are currently investigating an issue with generalized site slowness and intermittent timeouts. We will provide another update by 9:52 PM CT,