Back to overview
Downtime

The site is not responding

Jun 12 at 08:27am CDT
Affected services
Jobs
Candidate Search
Insights
Email / SMS Messaging
Interview Scheduling
Referrals
Background Checks
Reference Checks
Skills Tests
Onboarding

Resolved
Jun 12 at 08:35am CDT

We have successfully addressed the issue, resulting in the site being fully restored and functional once again. We apologize for any inconvenience this may have caused.

Created
Jun 12 at 08:27am CDT

The site currently not responding, The team is looking into it. We expect to be back online shortly