Back to overview
Degraded
Reference checks cannot be ordered
Oct 24 at 04:49pm CDT
Affected services
Reference Checks
Resolved
Nov 16 at 12:31pm CST
We have identified the root cause of why SkillSurvey orders were not processing for some users and have deployed a fix. All SkillSurvey orders should process as expected.
Affected services
Reference Checks
Created
Oct 24 at 04:49pm CDT
We are investigating an issue around reference check orders not processing after users complete the reference check ordering workflow.
Affected services
Reference Checks