Back to overview
Degraded

App slowness and pages not loading

May 07 at 12:58pm CDT
Affected services
Jobs
Candidate Search
Insights
Email / SMS Messaging
Interview Scheduling

Resolved
May 07 at 05:29pm CDT

The app slowness issue has been resolved, but the team will continue to monitor the app's performance in case further issues occur. Thank you all for your patience!

Created
May 07 at 12:58pm CDT

We are investigating reports of the app running slower than usual and in some cases pages not loading at all. We have not identified the root cause yet.