Back to overview
Degraded

Cloud hosting provider causing major outage

Oct 29 at 11:18am CDT
Affected services
Jobs
Candidate Search
Insights
Email / SMS Messaging
Interview Scheduling
Referrals
Login
Background Checks
Reference Checks
Skills Tests
Onboarding
Post-Hire Integrations

Resolved
Oct 29 at 06:30pm CDT

Instability with our underlying cloud provider has been resolved. We appreciate your patience and understanding!

Created
Oct 29 at 11:18am CDT

Systems are recovering following the cloud incident, but performance remains degraded. We are actively monitoring the situation.