Back to overview
Degraded

Indeed Apply Integration is Degraded

Nov 25 at 11:10am CST
Affected services
Jobs

Resolved
Nov 27 at 11:42am CST

We have deployed a fix and verified that Indeed Apply functionality has been restored. We apologize for the inconvenience and appreciate your patience!

Created
Nov 25 at 11:10am CST

Currently our Indeed Apply integration is degraded. This means that applicants are still able to apply, they will just be directed to apply via the career site link. We have already deployed a fix and will update here when this is resolved.