Back to overview
Degraded

Service Alert: Latency & Timeouts

Jan 05 at 01:56pm CST
Affected services
Jobs
Insights
Interview Scheduling
Login

Resolved
Jan 05 at 02:25pm CST

The latency and timeout issues have been resolved, and all systems are operating normally. Thank you for your patience.

Created
Jan 05 at 01:56pm CST

We are currently investigating reports of high latency and increased timeouts across our platform. Users may experience slow page loads or intermittent connection errors during this time.

Our engineering team is actively working on a fix, and we expect service to return to normal momentarily.

We apologize for the inconvenience and will provide another update as soon as the issue is fully resolved.